
T a n n e r  E D A L - E d i t ™  L a y o u t  E d i t o r

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Command Reference

�#File Menu

�#Edit Menu

�#View Menu

�#Draw Menu

�#Cell Menu

�#Setup Menu

�#Tools Menu

�#Window Menu

�#Help Menu

�#Key Commands



C o m m a n d  R e f e r e n c e F i l e  M e n u

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

File Menu

Command Default Shortcut Toolbar Button

File > New Ctrl+N

File > Open Ctrl+O

File > Close Ctrl+W

File > Save Ctrl+S

File > Save As

File > Import Mask Data

File > Export Mask Data

File > Replace Setup

File > Export Setup

File > Info

File > Print Ctrl+P

File > Print Preview

File > Print Setup

File > (recently used files)

File > Exit



C o m m a n d  R e f e r e n c e E d i t  M e n u

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Edit Menu

Command Default Shortcut Toolbar Button

Edit > Undo Ctrl+Z

Edit > Redo Ctrl+Y

Edit > Cut Ctrl+X

Edit > Copy Ctrl+C

Edit > Paste Ctrl+V

Edit > Paste to Layer Alt+V

Edit > Clear Del, Backspace

Edit > Duplicate Ctrl+D

Edit > Clipboard > Copy Window

Edit > Clipboard > Copy Selections

Edit > Select All Ctrl+A

Edit > Deselect All Alt+A

Edit > Find Ctrl+F

Edit > Find Next F

Edit > Find Previous P

Edit > Edit Object(s) Ctrl+E, double-click 
MOVE/EDIT mouse 
button



C o m m a n d  R e f e r e n c e E d i t  M e n u

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Edit > Edit In-Place > Push Into PgDn

Edit > Edit In-Place > Pop Out PgUp

Edit > Edit In-Place > View Top Cell End

Command Default Shortcut Toolbar Button



C o m m a n d  R e f e r e n c e V i e w  M e n u

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View Menu

Command Default Shortcut Toolbar Button

View > Insides > Toggle Insides Ctrl+I, TAB

View > Insides > Show Insides S

View > Insides > Hide Insides D

View > Insides > Hide Leaves Alt+L

View > Icon

View > Arrays

View > Ports

View > Grid

View > Origin

View > Home Home

View > Exchange X

View > Zoom > Mouse Z

View > Zoom > In +

View > Zoom > Out -

View > Zoom > To Selections W

View > Pan > To Selections Y

View > Pan > Left ←



C o m m a n d  R e f e r e n c e V i e w  M e n u

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Pan > Right →
View > Pan > Up ↑
View > Pan > Down ↓
View > Pan > To Cell Edge > Left Shift + ←
View > Pan > To Cell Edge > Right Shift + →
View > Pan > To Cell Edge > Up Shift + ↑
View > Pan > To Cell Edge > Down Shift + ↓
View > Objects > Boxes

View > Objects > Polygons

View > Objects > Wires

View > Objects > Circles

View > Objects > Ports

View > Objects > Rulers

View > Objects > Instances

View > Objects > Show All

View > Objects > Hide All

View > Layers > Show [Layer name]

View > Layers > Show All

View > Layers > Hide All

Command Default Shortcut Toolbar Button



C o m m a n d  R e f e r e n c e V i e w  M e n u

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Layers > Show Generated

View > Layers > Hide Generated

View > Cell Browser

View > Toolbars

View > Status Bar

View > Redraw Space

Command Default Shortcut Toolbar Button



C o m m a n d  R e f e r e n c e D r a w  M e n u

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Draw Menu

Command Default Shortcut Toolbar Button

Draw > Move By

Draw > Nudge > Left Ctrl + ←
Draw > Nudge > Right Ctrl + →
Draw > Nudge > Up Ctrl + ↑
Draw > Nudge > Down Ctrl + ↓
Draw > Rotate R

Draw > Flip > Horizontal H

Draw > Flip > Vertical V

Draw > Nibble Alt+X

Draw > Slice > Horizontal

Draw > Slice > Vertical

Draw > Merge

Draw > Group Ctrl+G

Draw > Ungroup Ctrl+U

Draw > Pick Layer A



C o m m a n d  R e f e r e n c e C e l l  M e n u

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Cell Menu

Command Default Shortcut Toolbar Button

Cell > New N

Cell > Open O

Cell > Copy C

Cell > Rename T

Cell > Delete B

Cell > Revert Cell

Cell > Close As

Cell > Instance I, Ins

Cell > Flatten

Cell > Fabricate

Cell > Info



C o m m a n d  R e f e r e n c e S e t u p  M e n u

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Setup Menu

Command Default Shortcut Toolbar Button

Setup > Palette

Setup > Application

Setup > Design

Setup > Layers double-click layer icon

Setup > Special Layers

Setup > DRC

Setup > SPR



C o m m a n d  R e f e r e n c e T o o l s  M e n u

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Tools Menu

Command Default Shortcut Toolbar Button

Tools > Clear Rulers

Tools > Generate Layers

Tools > Clear Generated Layers

Tools > DRC

Tools > DRC Box

Tools > Clear Error Layer

Tools > Place and Route

Tools > Extract

Tools > Cross Section

Tools > Macro

Tools > Repeat Macro



C o m m a n d  R e f e r e n c e W i n d o w  M e n u

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Window Menu

Command Default Shortcut Toolbar Button

Window > Cascade

Window > Tile Horizontally

Window > Tile Vertically

Window > Arrange Icons

Window > Close All Except Active

Window > (open windows list)



C o m m a n d  R e f e r e n c e H e l p  M e n u

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Help Menu

Command Default Shortcut Toolbar Button

Help > L-Edit User Guide

Help > About L-Edit

Memory

Support



C o m m a n d  R e f e r e n c e K e y  C o m m a n d s

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Key Commands

The following table lists default key commands not associated with any menu
item. All key commands in L-Edit (including default shortcuts) can be
reprogrammed through Setup Application – Keyboard .

Command Description

Q Toggles the locator bar to display coordinates and 
distance relative to the cursor’s initial position.



C o m m a n d  R e f e r e n c e F i l e  >  N e w

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

File > New

Creates a new file.

File Menu

File Type The type of file to create. Layout  produces a 
Tanner Database (TDB) file. Text  creates an 
ASCII text file for normal text editing.

Copy TDB setup from file For Layout  files, the TDB file from which to 
take setup information for the new file. TDB 
files that are currently loaded and in the 
directories predefined by the 
Setup > Application  menu command are 
listed. If no file is selected the new file is 
opened with the default empty setup (black 
background, single layer, no DRC rules).



C o m m a n d  R e f e r e n c e F i l e > O p e n

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

File > Open

Opens an existing file.

File Menu

Look in The source directory, with a list of its parent 
directory and its subdirectories, any of which 
may be chosen as the new source directory.

File name The name of the file to be opened. The 
wildcard character * can be used to narrow 
down the list of available files. (For example, 
to list only TDB files whose names begin with 
the letter a, type a*.tdb  and press Return .) 
Only one file can be opened at a time. All files 
of the specified type in the source directory are 
listed.



C o m m a n d  R e f e r e n c e F i l e > O p e n

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Files of type The type of file listed. There are two 
predefined types: TDB (Tanner Database) and 
text files with the extension .ext , .ttx , .txt , or 
.xst . All files in the source directory (*.*) can 
be displayed; however, only TDB or text files 
can be opened with the File > Open  command.

Open as read-only Opens the TDB file as read-only. When this 
option is checked, any changes made to the file 
cannot be saved.



C o m m a n d  R e f e r e n c e F i l e  >  C l o s e

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

File > Close

Closes the active file. If it has not been saved since the last change, a warning
appears asking if the file should be saved.

File Menu



C o m m a n d  R e f e r e n c e F i l e  >  S a v e

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

File > Save

Saves the active file using the same name, path, and format as when last saved. If
the current file has not been saved previously, the File > Save As  dialog appears.

File Menu



C o m m a n d  R e f e r e n c e F i l e  >  S a v e  A s

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

File > Save As

Saves the active file under a new name.

File Menu

Save in The target directory into which the file is to be 
saved, with a list of its parent directory and its 
subdirectories, any of which may be chosen as 
the new target directory.

File name The file name by which the active window is to 
be saved. The wildcard character * can be used 
to search for a previously-named file (see 
File > Open ). The saved file must have a 
specific name. All files of the specified type in 
the target directory are listed.



C o m m a n d  R e f e r e n c e F i l e  >  S a v e  A s

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Save as type The type of file listed. Layout  files must be 
saved as TDB (Tanner Database) format, either 
in the current version 7.0 or version 6.x. There 
is no predefined type for Text  files. (See File > 
New for information on Layout  and Text  file 
types.)



C o m m a n d  R e f e r e n c e F i l e  >  I m p o r t  M a s k  D a t a

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

File > Import Mask Data

Imports an existing CIF or GDS II file into a layout document.

File Menu

From file The name of the .cif  or .gds  file to import. 
Clicking the Browse  button opens the 
File > Open  dialog with CIF Files  and GDSII 
Files  listed as predefined types.

Import file type Either CIF (Caltech Intermediate Form) or 
GDSII (stream).

Use setup file The TDB file from which to take layout setup 
information for the imported file. If no setup 
file is specified L-Edit asks whether to 
Generate new layers for all unknown layers 
automatically  or Place objects on all 
unknown layers to the Icon Layer .



C o m m a n d  R e f e r e n c e F i l e  >  I m p o r t  M a s k  D a t a

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

When a CIF file is selected, additional import options are available. Clicking the
Options  button opens the Import CIF Options  dialog.

Read rectangular polygons 
as boxes

When this box is checked, all orthogonal, 
rectangular polygons are read in as boxes. 
Boxes consume less memory and draw faster 
than polygons. For more information see 
Extensions.



C o m m a n d  R e f e r e n c e F i l e  >  E x p o r t  M a s k  D a t a

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

File > Export Mask Data

Exports an existing layout data into a mask document.

Both CIF and GDSII file types have additional export options. Clicking the
Options  button opens the Export CIF Options  or Export GDSII Options  dialog.

File Menu

To file The name of the target file. Clicking the 
Browse  button opens the File > Save As  
dialog with CIF Files  and GDS II Files  listed as 
predefined types.

Export file type Either CIF (Caltech Intermediate Form) or 
GDSII (stream).



C o m m a n d  R e f e r e n c e F i l e  >  E x p o r t  M a s k  D a t a

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

For CIF:

For GDSII:

Write Port-boxes 
(Nonstandard!)

L-Edit writes out ports using the 94 CIF 
extension, where the port’s label is written 
along with the center of the port box. When 
this box is checked, L-Edit writes port boxes 
using the center/length/width syntax of CIF 
boxes. This does not conform to standard CIF 
syntax. For more information see Extensions.

Use default GDSII units 
(0.001 micron)

When this box is checked, the dimensions of 
objects are converted into units of 0.001 
micron (the default GDSII database unit) when 
written into the GDSII file. For example, a 
10×10 box with 1 internal unit = 1 lambda = 1 
micron in the L-Edit layout would be recorded 
in the GDS II file as having dimensions of 
10,000×10,000 database units. When this 
GDSII file is reopened, the technology setup is 
automatically changed so that the resulting box 
is 10×10 microns = 10,000×10,000 internal 
units in size.



C o m m a n d  R e f e r e n c e F i l e  >  E x p o r t  M a s k  D a t a

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

When this box is not checked, the dimensions 
of objects are written into the GDSII file as 
specified, with an appropriate comment on the 
units being used. No technology setup changes 
are made when the file is reopened.

Convert all cell names to 
uppercase

Some GDSII systems do not recognize 
lowercase letters. When this box is checked, 
L-Edit changes all letters written to a GDSII 
file to uppercase.

Write circles as … sided 
polygons

By default, L-Edit circles are written as 
64-sided polygons. The number of sides can be 
changed here.



C o m m a n d  R e f e r e n c e F i l e  >  R e p l a c e  S e t u p

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

File > Replace Setup

Replaces or merges setup information from another file to use in the active
document.

File Menu

From file The file from which the information is to be 
read. You can choose from available .tdb  or 
.ttx  files with the Browse  button.

Layers Under General Setup , if the Layers  box is 
checked, layer setup information is updated on 
a layer-by-layer basis.There are two update 
options: Replace  causes setup information 
from the source file to overwrite the setup 
information of the active file; Merge  causes all 
layers present in both the source and 
destination files to be present in the destination 
file after the operation. Layers not originally 
present in the destination file before the merge 
are added to the end of the layer list. 



C o m m a n d  R e f e r e n c e F i l e  >  R e p l a c e  S e t u p

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Layers  (continued) Under Replace , check boxes indicate that CIF 
names , GDS II numbers , and Wire settings  
from the source file are replaced in the 
destination file. (See Setup > Layers  for 
information on layers setup.)

Technology Under General setup , if the Technology  box 
is checked, technology setup information in the 
source file replaces the technology information 
in the destination file. When the Maintain 
physical size option is on, the internal units 
are changed to reflect the relationship between 
physical units and internal units. When the 
Rescale  option is on, mapping of physical 
units to internal units is rescaled.

Replace Setup information to be replaced in the 
destination file. Includes Drawing , Palette , 
Grid , Selection , and Show/Hides . (See Setup 
Menu commands and show/hide commands in 
the View Menu for an explanation of the 
different check boxes.)

Replace DRC setup When the DRC rules  check box is on, design 
rules in the source file replace those in the 
destination file. (See Setup > DRC  for 
information on design rules.)



C o m m a n d  R e f e r e n c e F i l e  >  R e p l a c e  S e t u p

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Note: The Replace SPR setup  options are disabled when the source file is in TTX
format.

Replace SPR setup Check boxes indicate which SPR setup 
information (Core , Padframe , Pad route ) to 
replace in the destination file. When the Place 
and Route run configuration  check box is 
checked, the information from the Tools > 
Place and Route  dialog in the source file 
replaces the information in the destination file.



C o m m a n d  R e f e r e n c e F i l e  >  E x p o r t  S e t u p

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

File > Export Setup

Exports setup information in the active document to a Tanner Text Format File
(TTX). The resulting TTX file can be read back into L-Edit with File > Replace
Setup . TTX files may be edited with the L-Edit text editor or any other ASCII
text editor.

File Menu

To file The name of the target file. Clicking the 
Browse  button opens the File > Save As  
dialog with Tanner Text Format Files listed as 
the predefined type.

Layers Check boxes indicate what layer setup 
information to save in the TTX file. Includes 
Layers , Layer derivation , CIF names , GDS II 
numbers , and Wire settings . (See Setup > 
Layers  for more information.)



C o m m a n d  R e f e r e n c e F i l e  >  E x p o r t  S e t u p

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

General Check boxes indicate general setup 
information to save in the TTX file. Includes 
Technology , Drawing , Palette , Grid , and 
Selections . (See the Setup Menu° for more 
information.)

DRC When the DRC box is checked, design rules are 
saved to the TTX file.



C o m m a n d  R e f e r e n c e F i l e  >  I n f o

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

File > Info

Displays general information for the active TDB file. 

File Menu

File path The name and path of the active document.

File info Includes Author , Organization , and 
Information  (notes or messages) for the active 
document. Text fields can be edited.

File lock Check box toggles locking of the file contents. 
Locked files cannot be edited, but their 
contents can be copied to other files.



C o m m a n d  R e f e r e n c e F i l e  >  I n f o

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

File dates and versions The date and time the file was created and last 
revised. Setup info  and Layout info  include 
version numbers. The version numbering 
system provides an internal accounting method 
for tracking layout design and file setup 
changes. Major numbers are increased by 
clicking the Increment  button; minor numbers 
are automatically incremented each time 
changes in the file are saved.



C o m m a n d  R e f e r e n c e F i l e  >  P r i n t

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

File > Print

Prints the active cell.

File Menu

Printer The device to which the data in the active 
window will be printed.

Properties Accesses a Printer Properties  dialog.

Print to file When this box is checked the data in the active 
window is printed to a printer file (.prn ). 

Print range Page range to be printed.

Copies Number and order of copies to be printed.

Layout area The portion of the Layout Area to print. 
Options are Entire cell  or Current window 
only .

Resolution The printer resolution in dots per inch (dpi). 
Best  automatically matches the appropriate 
resolution for the printer.



C o m m a n d  R e f e r e n c e F i l e  >  P r i n t

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Scaling Option buttons control the magnification of the 
layout on the printed page. Pages  refers to the 
number of pages (width × height) that the 
printed layout will occupy. For example, a 3×2 
page scale will result in a layout that spans 6 
printed pages: 3 wide and 2 high. Multiple 
pages can be pasted together after printing to 
create the layout as on the screen. 

Locator Units per is the number of locator 
units to be printed per physical unit on the 
page. Inch  and centimeter  are available for 
selection from the drop-down menu.



C o m m a n d  R e f e r e n c e F i l e  >  P r i n t  P r e v i e w

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

File > Print Preview

Displays the active cell as it will be printed in full-page mode. Cells cannot be
edited in Print Preview .

File Menu



C o m m a n d  R e f e r e n c e F i l e  >  P r i n t  S e t u p

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

File > Print Setup

Changes the printer and printing options.

File Menu

Printer The default device to which the data in the 
active window will be printed.

Properties Accesses a Printer Properties  dialog.

Paper The size and source of the paper.

Orientation Whether the long side of the page(s) printed 
will be vertical or horizontal relative to the 
objects.

Layout area The portion of the Layout Area to print. 
Options are Entire cell  or Current window 
only .

Resolution The printer resolution in dots per inch (dpi). 
Best  automatically matches the appropriate 
resolution for the printer.



C o m m a n d  R e f e r e n c e F i l e  >  P r i n t  S e t u p

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Scaling Scaling options for the printed page. See File > 
Print  for a more detailed description.



C o m m a n d  R e f e r e n c e F i l e  >  ( r e c e n t l y  u s e d  f i l e s )

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

File > (recently used files)

Recently used files can be reopened directly, bypassing the File > Open
command. The most recently used files are listed first.

File Menu



C o m m a n d  R e f e r e n c e F i l e  >  E x i t

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

File > Exit

Exits L-Edit. A warning appears for each unsaved file, asking if it should be
saved.

File Menu



C o m m a n d  R e f e r e n c e E d i t  >  U n d o

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Edit > Undo

Reverses the previous editing operation. Only those operations that directly
affect objects — drawing, copying, editing, moving, instancing, grouping,
flipping, rotating, slicing, and merging — can be undone. Multiple operations
can be undone, in reverse order.

Edit Menu



C o m m a n d  R e f e r e n c e E d i t  >  R e d o

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Edit > Redo

Reverses the previous Undo  command. Multiple Undo  operations can be redone,
in reverse order.

Edit Menu



C o m m a n d  R e f e r e n c e E d i t  >  C u t

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Edit > Cut

Removes the selected objects from the Layout Area of the active cell and places
them on the internal L-Edit clipboard. The contents of the clipboard can be
pasted to the Layout Area with Edit > Paste .

Edit Menu



C o m m a n d  R e f e r e n c e E d i t  >  C o p y

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Edit > Copy

Copies the selected objects from the Layout Area of the active cell to the internal
L-Edit clipboard. The contents of the clipboard can be pasted to the Layout Area
with Edit > Paste .

Edit Menu



C o m m a n d  R e f e r e n c e E d i t > P a s t e

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Edit > Paste

Inserts the contents of the internal L-Edit clipboard into the Layout Area of the
active cell.

Edit Menu



C o m m a n d  R e f e r e n c e E d i t  >  P a s t e  t o  L a y e r

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Edit > Paste to Layer

Inserts the contents of the internal L-Edit clipboard onto the current layer in the
Layout Area of the active cell.

Edit Menu



C o m m a n d  R e f e r e n c e E d i t  >  C l e a r

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Edit > Clear

Deletes the selected objects from the Layout Area of the active cell. Cleared
objects are not put onto the internal L-Edit clipboard.

Edit Menu



C o m m a n d  R e f e r e n c e E d i t  >  D u p l i c a t e

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Edit > Duplicate

Creates a duplicate of the selected object(s) and places it in the Layout Area of
the active cell, one snap grid point apart from the originals. The new objects are
selected and can be moved to a new offset. Subsequent Duplicate  commands will
place duplicates at the same offset from the new originals, aiding in the rapid
creation of regular structures like arrays. Duplicate  does not affect the contents
of the internal L-Edit clipboard.

Edit Menu



C o m m a n d  R e f e r e n c e E d i t  >  C l i p b o a r d  >  C o p y  W i n d o w

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Edit > Clipboard > Copy Window

Copies the view of the active cell to the Windows clipboard as a bitmap. Hidden
objects are not copied.

Edit Menu



C o m m a n d  R e f e r e n c e E d i t  >  C l i p b o a r d  >  C o p y  S e l e c t i o n s

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Edit > Clipboard > Copy Selections

Copies selected objects in the Work Area of the active cell to the Windows
clipboard as a bitmap. Selected objects not visible in the Work Area are not
copied.

Edit Menu



C o m m a n d  R e f e r e n c e E d i t  >  S e l e c t  A l l

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Edit > Select All

Selects all objects in the active cell.

Edit Menu



C o m m a n d  R e f e r e n c e E d i t  >  D e s e l e c t  A l l

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Edit > Deselect All

Deselects all objects in the active cell.

Edit Menu



C o m m a n d  R e f e r e n c e E d i t  >  F i n d

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Edit > Find

Searches for and selects items according to specified criteria.

Edit Menu

Find what A Box , Circle , Polygon , Ruler , and/or Wire  
search finds the object(s) on the specified 
layer. A Port  search finds ports by name on the 
specified layer. When no layer is specified the 
search finds the items on all layers. An 
Instance  search finds instances by Instance 
name  or by originating Cell name . 

Change view after finding The view can be set to Pan or to Pan & Zoom  
to the found item, or to No change .

Match whole names only If this box is checked, only exact matches to 
the specified text will be found. Otherwise, any 
port or instance which contains the search term 
as a portion of the full name will be selected.

Match case If this box is checked, only text which matches 
the case of the specified text will be found.



C o m m a n d  R e f e r e n c e E d i t  >  F i n d

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Find next Finds and selects the next matching item.

Find all Finds and selects all matching items at once.



C o m m a n d  R e f e r e n c e E d i t  >  F i n d  N e x t

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Edit > Find Next

Searches for and selects the next object satisfying the criteria defined by Edit >
Find . If the Find  command has not yet been executed, the Find Object(s)  dialog
is opened.

Edit Menu



C o m m a n d  R e f e r e n c e E d i t  >  F i n d  P r e v i o u s

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Edit > Find Previous

Searches for and selects previously found objects satisfying the criteria defined
by Edit > Find . If the Find  command has not yet been executed, the Find
Object(s)  dialog is opened.

Edit Menu



C o m m a n d  R e f e r e n c e E d i t  >  E d i t  O b j e c t ( s )

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Edit > Edit Object(s)

Opens the Editing Object(s)  dialog and prompts for textual edits to
characteristics of the selected objects.

Note: When multiple objects with different properties are selected, the affected fields
appear as dark gray to represent multiple values for those properties. This is
called mixed-value appearance. In the following tables, unless otherwise stated,
all fields take on this characteristic when multiple objects are selected. Unlike
disabled light gray (“grayed-out”) fields, fields with the mixed-value appearance
can be edited. All selected objects take on the value entered in one of these fields.

Edit Menu

On layer The current layer on which the objects reside. 
This can be changed by selecting a layer from 
the drop-down list; all selected objects will 
convert to the new layer.



C o m m a n d  R e f e r e n c e E d i t  >  E d i t  O b j e c t ( s )

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

The Editing Object(s)  dialog contains seven tabs:

� Boxes

� Polygons

� Wires

� Circles

� Ports

� Rulers

� Instances

Each tab indicates the number of selected objects of that type in parentheses.

Data type An integer primarily used by GDS II database 
users who intend to write out a GDS II file 
from L-Edit and read it into another program 
requiring additional information. Data type 
information is ignored by L-Edit.



C o m m a n d  R e f e r e n c e E d i t  >  E d i t  O b j e c t ( s )

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Edit Object(s) – Boxes

Edit Object(s) – Polygons

Note: Only a single polygon can be edited at a time. If multiple polygons are selected,
the Vertices (Locator Units)  list on the Polygons  tab is disabled.

Coordinates (Locator 
Units)

The X and Y coordinates of the selected boxes’ 
lower left and upper right vertices. 

Vertices (Locator Units) The X and Y coordinates of the selected 
polygon’s vertices. Add Vertex  creates a new 
vertex with the selected coordinates. Delete 
vertex  removes the selected vertex from the 
object.



C o m m a n d  R e f e r e n c e E d i t  >  E d i t  O b j e c t ( s )

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Edit Object(s) – Wires

Note: Only a single wire’s vertices can be edited at a time. If multiple wires are

Vertices (Locator Units) The X and Y coordinates of the selected wire’s 
vertices. Add Vertex  creates a new vertex with 
the selected coordinates. Delete vertex  
removes the selected vertex from the object.

Wire width The width of the selected wires in Locator 
units.

Join style The type of join for the wires. A drop-down 
menu lists the 4 styles: Layout , Round , Bevel , 
or Miter . (See Wire Styles for more 
information on join styles.)

End style The type of end for the wires. A drop-down 
menu lists the 3 styles: Butt , Round , or 
Extend . See Wire Styles for more information 
on end styles.)

Angle The angle between two segments in a Miter 
style join. (See Wire Styles for more 
information on a Miter join.)



C o m m a n d  R e f e r e n c e E d i t  >  E d i t  O b j e c t ( s )

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

selected, the Vertices (Locator Units)  list on the Wires  tab is disabled.



C o m m a n d  R e f e r e n c e E d i t  >  E d i t  O b j e c t ( s )

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Edit Object(s) – Circles

Edit Object(s) – Ports

Edit Object(s) – Rulers

Coordinates (Locator 
Units)

The Radius  of the selected circle(s) and the 
center’s X and Y coordinates.

Port name The visible text associated with the selected 
ports.

Text size The size of the on-screen text, in Locator Units, 
for the selected ports.

Coordinates (Locator 
Units)

The X and Y coordinates of the selected ports’ 
lower left and upper right vertices.

Size The letter height, in Locator Units, for text 
associated with the ruler.



C o m m a n d  R e f e r e n c e E d i t  >  E d i t  O b j e c t ( s )

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Display Ruler text can be displayed in one of four 
ways: No text , Centered , At end points , or At 
tick marks (Major). Select the desired option 
from the drop-down list.

Angle The angle at which the text is displayed.

Show text on the other side 
of the ruler

Moves the text to the opposite side of the line.

Visible Check box toggles the visibility of tick marks. 
When this box is unchecked, text that is 
displayed At tick marks  in the Display  
drop-down list will not be visible.

Major The distance, in Locator Units, between major 
tick marks.

Minor The distance, in Locator Units, between minor 
tick marks.

Symmetric When this box is checked tick marks are 
symmetrical around the ruler line.

End style Select the desired end style by highlighting the 
illustration in the drop-down list.

Start point (Locator Units) The X and Y coordinates, in Locator Units, of 
the beginning of the ruler.



C o m m a n d  R e f e r e n c e E d i t  >  E d i t  O b j e c t ( s )

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Edit Object(s) – Instances

End point (Locator Units) The X and Y coordinates, in Locator Units, of 
the end of the ruler.

Instance of cell The instanced cell. Clicking the Change  button 
opens the Select cell to instance  dialog. If 
more than one instance is selected the field is 
disabled.

Instance name Identifies the instance or array in the active 
cell. This name is assigned by L-Edit if the 
space is left blank. Each instance in a cell must 
have a unique name. If more than one instance 
is selected the field is disabled.



C o m m a n d  R e f e r e n c e E d i t  >  E d i t  O b j e c t ( s )

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Rotation angle The integer angle by which the instance is 
rotated. The coordinate axes illustration is 
updated as the angle is changed. Coordinates of 
arrays are specified with respect to the 
instanced cell. If the underlying subgrid is 
insufficient for accurate rendering of the 
rotated instance, a warning appears, suggesting 
the grid be rescaled. This occurs if the mouse 
snap grid parameter is less than 100. (See 
Setup Design – Grid  for information on the 
mouse grid.) The physical sizes of objects are 
unchanged.

Mirror When this box is checked, the instance’s 
coordinate system is flipped horizontally. The 
coordinate axes illustration reflects the change.

Translation (Locator Units) The position of the instance with respect to the 
origin of the instancing cell, in Locator Units. 
When first created, an instance is placed at the 
center of the active Work Area. Moving the 
instance changes the X and Y coordinates.



C o m m a n d  R e f e r e n c e E d i t  >  E d i t  O b j e c t ( s )

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Scale factor A fraction that defines the scaling of the 
instance relative to the original cell. The top 
box is the numerator, the bottom box the 
denominator. This factor is applied to each 
coordinate of all objects in the instanced cell. 
Scalable instances are fully supported in both 
GDSII and CIF formats. (CIF output results in 
the creation of new cells which are scaled 
versions of the originals. CIF does not support 
instance-based scaling.)

Array parameters Repeat count  is the number of times the 
instance is to be arrayed in the X and Y 
directions of the instanced cell’s coordinate 
system. Delta (Locator Units) refers to the X 
and Y spacing between array elements. The 
distance is measured from the lower left corner 
of each array element in the instanced cell’s 
coordinate system: ∆x increases to the right, ∆y 
increases upwards. If both of these numbers are 
zero, all of the array elements will be placed 
exactly on top of one another.



C o m m a n d  R e f e r e n c e E d i t  >  E d i t  I n - P l a c e  >  P u s h  I n t o

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Edit > Edit In-Place > Push Into

Allows the contents of an instance to be edited within the current cell without
directly opening its originating cell. Regular geometry, other instances, and
arrays can be edited. Multiple Push Into  commands can be invoked to edit
instances all the way down the hierarchy. 

Edit Menu



C o m m a n d  R e f e r e n c e E d i t  >  E d i t  I n - P l a c e  >  P o p  O u t

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Edit > Edit In-Place > Pop Out

Terminates an Edit > Edit In-Place > Push Into  editing session in an instance
and “pops” up to the next higher-level (instancing) cell.

Edit Menu



C o m m a n d  R e f e r e n c e E d i t  >  E d i t  I n - P l a c e  >  V i e w  T o p  C e l l

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Edit > Edit In-Place > View Top Cell

Displays the home view of the top-level cell.

Edit Menu



C o m m a n d  R e f e r e n c e V i e w  >  I n s i d e s  >  T o g g l e  I n s i d e s

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Insides > Toggle Insides

Toggles the visibility of instance contents for all instances in the active cell. Ports
and objects on the Icon layer are not affected by the command. (See View > Icon
for information on the Icon layer.)

Edit Menu



C o m m a n d  R e f e r e n c e V i e w  >  I n s i d e s  >  S h o w  I n s i d e s

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Insides > Show Insides

Displays the contents of the selected instances.

Edit Menu



C o m m a n d  R e f e r e n c e V i e w  >  I n s i d e s  >  H i d e  I n s i d e s

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Insides > Hide Insides

Hides the contents of the selected instances.

Edit Menu



C o m m a n d  R e f e r e n c e V i e w  >  I n s i d e s  >  H i d e  L e a v e s

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Insides > Hide Leaves

Hides all leaf-level cells in the hierarchy. A leaf cell contains no instances.

Edit Menu



C o m m a n d  R e f e r e n c e V i e w  >  I c o n

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Icon

Toggles the visibility of lower-level geometry in conjunction with View >
Insides > Toggle Insides  being off. When Icon  is on, the objects in the instance
residing on the Icon layer are shown and the rest of the instance’s contents are
hidden.

Many IC fabricators allow the identification of an Icon layer whose geometry is
ignored during fabrication. Exactly one L-Edit layer may be specified as the Icon
layer (see Setup > Special Layers ). Objects on the Icon layer can be used to
annotate an instanced cell or highlight one cell’s relationship to another.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  A r r a y s

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Arrays

Toggles the visibility of instance contents in arrays in the active cell. When
Arrays  is on, all arrays are shown in full, with all repeated instances visible.
When Arrays  is off, arrays are displayed as single instances with only one
element per array visible.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  P o r t s

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Ports

Toggles the visibility of ports within instances. When Ports  is on, all ports inside
instances and at the top level are shown. When Ports  is off, only top-level ports
are shown. Ports on hidden layers are never shown.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  G r i d

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Grid

Toggles the visibility of the displayed grid (not the mouse snap grid) when the
Grid layer is shown. (See Setup > Layers  for information on showing/hiding
layers.) The displayed grid will not be visible under all magnifications.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  O r i g i n

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Origin

Toggles the visibility of the crosshair marker that indicates the origin (0,0) when
the Origin layer is shown. (See Setup > Layers  for information on showing/
hiding layers.) The origin will only be visible if it is within the Work Area.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  H o m e

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Home

Zooms the view to fit all of the contents of the active cell within the Work Area.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  E x c h a n g e

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Exchange

Exchanges the current view of the Work Area (result of a pan or zoom operation)
with the previous view.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  Z o o m  >  M o u s e

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Zoom > Mouse

Enters mouse zoom mode for one operation. The mouse buttons are redefined:
the DRAW button becomes the ZOOM IN button, the MOVE/EDIT button
becomes the PAN button, and the SELECT button becomes the ZOOM OUT
button.

View Menu

Zoom In Can be clicked at a single point or can be used 
to drag out a rectangle. Clicking at a single 
point magnifies the general area about the 
mouse pointer by a factor of two. Dragging 
with the button held allows you to specify a 
rectangle in any portion of the Work Area. 
When the button is released, L-Edit zooms the 
Work Area directly to the area inside the 
rectangle. L-Edit must maintain the correct 
height-to-width ratio of the display, so the new 
Work Area may not be exactly the region 
outlined by the rectangle.



C o m m a n d  R e f e r e n c e V i e w  >  Z o o m  >  M o u s e

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

After the operation, the mouse buttons revert to their previous functions.

Pan Can be clicked at a single point or used to drag 
out a direction. Clicking pans the Work Area so 
that the new center is located at the pointer’s 
position. Dragging with the button held allows 
you to control the distance and direction of the 
pan. As you drag, an outline of the window 
moves with the pointer. When the button is 
released, L-Edit pans the view so that objects 
contained in the final outline are visible.

Zoom Out Clicking zooms the Work Area out from the 
location of the pointer.



C o m m a n d  R e f e r e n c e V i e w  >  Z o o m  >  I n

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Zoom > In

Magnifies the central portion of the Work Area by a factor of two, reducing the
visible portion of the Layout Area.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  Z o o m  >  O u t

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Zoom > Out

Reduces the magnification of the central portion of the Work Area by a factor of
two, enlarging the visible portion of the Layout Area.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  Z o o m  >  T o  S e l e c t i o n s

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Zoom > To Selections

Zooms the Work Area view to the minimum bounding box (MBB) of the
selected items. Aspect ratio constraints are maintained.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  P a n  >  T o  S e l e c t i o n s

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Pan > To Selections

Moves the Work Area view to place selected objects at the center.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  P a n  >  L e f t

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Pan > Left

Moves the Work Area view a quarter-width to the left.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  P a n  >  R i g h t

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Pan > Right

Moves the Work Area view a quarter-width to the right.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  P a n  >  U p

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Pan > Up

Moves the Work Area view a quarter-height up.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  P a n  >  D o w n

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Pan > Down

Moves the Work Area view a quarter-height down.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  P a n  >  T o  C e l l  E d g e  >  L e f t

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Pan > To Cell Edge > Left

Moves the Work Area view so that the left edge is flush with the left edge of the
contents of the active cell.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  P a n  >  T o  C e l l  E d g e  >  R i g h t

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Pan > To Cell Edge > Right

Moves the Work Area view so that the right edge is flush with the right edge of
the contents of the active cell.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  P a n  >  T o  C e l l  E d g e  >  U p

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Pan > To Cell Edge > Up

Moves the Work Area view so that the top edge is flush with the top edge of the
contents of the active cell.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  P a n  >  T o  C e l l  E d g e  >  D o w n

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Pan > To Cell Edge > Down

Moves the Work Area view so that the bottom edge is flush with the bottom edge
of the contents of the active cell.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  O b j e c t s  >  B o x e s

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Objects > Boxes

Toggles the visibility of boxes in all open files. When boxes are hidden, the Box
tool on the Drawing toolbar is shaded and disabled.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  O b j e c t s  >  P o l y g o n s

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Objects > Polygons

Toggles the visibility of polygons in all open files. When polygons are hidden,
the Polygon  tools on the Drawing toolbar are shaded and disabled.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  O b j e c t s  >  W i r e s

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Objects > Wires

Toggles the visibility of wires in all open files. When wires are hidden, the Wire
tools on the Drawing toolbar are shaded and disabled.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  O b j e c t s  >  C i r c l e s

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Objects > Circles

Toggles the visibility of circles in all open files. When circles are hidden, the
Circle  tool on the Drawing toolbar is shaded and disabled.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  O b j e c t s  >  P o r t s

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Objects > Ports

Toggles the visibility of ports in all open files. When ports are hidden, the Port
tools on the Drawing toolbar is shaded and disabled.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  O b j e c t s  >  R u l e r s

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Objects > Rulers

Toggles the visibility of rulers in all open files. When rulers are hidden, the Ruler
tools on the Drawing toolbar are shaded and disabled.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  O b j e c t s  >  I n s t a n c e s

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Objects > Instances

Toggles the visibility of instances in all open files. When instances are hidden,
the Instance  tool on the Drawing toolbar is shaded and disabled.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  O b j e c t s  >  S h o w  A l l

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Objects > Show All

Displays all objects in all open files.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  O b j e c t s  >  H i d e  A l l

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Objects > Hide All

Hides all objects in all open files except for the tool type currently selected. All
hidden drawing tools are shaded and disabled.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  L a y e r s  >  S h o w  [ L a y e r  n a m e ]

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Layers > Show [ Layer name ]

Toggles the visibility of the selected layer in the active file. When a layer is
hidden, its icon on the Layer Palette is shaded and disabled.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  L a y e r s  >  S h o w  A l l

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Layers > Show All

Displays all mask layers in the active file.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  L a y e r s  >  H i d e  A l l

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Layers > Hide All

Hides all mask layers in the active file except for the layer currently selected. All
hidden layer icons become shaded and disabled on the Layer Palette.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  L a y e r s  >  S h o w  G e n e r a t e d

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Layers > Show Generated

Displays all generated layers in the active file. (See Tools > Generate Layers  for
information on generated layers.)

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  L a y e r s  >  H i d e  G e n e r a t e d

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Layers > Hide Generated

Hides all generated layers except for the generated layer currently selected on the
Layer Palette. All hidden generated layer icons on the Layer Palette are shaded
and disabled. (See Tools > Generate Layers  for information on generated
layers.)

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  C e l l  B r o w s e r

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Cell Browser

Opens the hierarchical list of cells for the active file.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  T o o l b a r s

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Toolbars

Displays the list of available toolbars: Standard , Drawing , Layers , Locator , and
Mouse buttons . Checks indicate which toolbars are currently displayed.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  S t a t u s  B a r

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Status Bar

Toggles the visibility of the Status Bar.

View Menu



C o m m a n d  R e f e r e n c e V i e w  >  R e d r a w

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

View > Redraw

Redraws the active layout window.

View Menu



C o m m a n d  R e f e r e n c e D r a w  >  M o v e  B y

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Draw > Move By

Opens the Move By  dialog.

Draw Menu

Move amount (Locator 
Units)

Moves selected objects in the active cell by a 
specified number of Locator Units in the X and 
Y directions.



C o m m a n d  R e f e r e n c e D r a w  >  N u d g e  >  L e f t

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Draw > Nudge > Left

Moves (“nudges”) the selected objects to the left by a predetermined distance.
The distance moved is set by the Setup Design – Drawing  command.

Draw Menu



C o m m a n d  R e f e r e n c e D r a w  >  N u d g e  >  R i g h t

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Draw > Nudge > Right

Moves (“nudges”) the selected objects to the right by a predetermined distance.
The distance moved is set by the Setup Design – Drawing  command.

Draw Menu



C o m m a n d  R e f e r e n c e D r a w  >  N u d g e  >  U p

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Draw > Nudge > Up

Moves (“nudges”) the selected objects up by a predetermined distance. The
distance moved is set by the Setup Design – Drawing  command.

Draw Menu



C o m m a n d  R e f e r e n c e D r a w  >  N u d g e  >  D o w n

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Draw > Nudge > Down

Moves (“nudges”) the selected objects down by a predetermined distance. The
distance moved is set by the Setup Design – Drawing  command.

Draw Menu



C o m m a n d  R e f e r e n c e D r a w  >  R o t a t e

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Draw > Rotate

Rotates the selected objects in the active cell counterclockwise 90°. The rotation
takes place around the center of the set of all selected objects.

Draw Menu



C o m m a n d  R e f e r e n c e D r a w  >  F l i p  >  H o r i z o n t a l

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Draw > Flip > Horizontal

Flips the selected objects in the active cell horizontally. The flip takes place
around the vertical axis through the center of the set of all selected objects.

Draw Menu



C o m m a n d  R e f e r e n c e D r a w  >  F l i p  >  V e r t i c a l

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Draw > Flip > Vertical

Flips the selected objects in the active cell vertically. The flip takes place around
the horizontal axis through the center of the set of all selected objects.

Draw Menu



C o m m a n d  R e f e r e n c e D r a w  >  N i b b l e

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Draw > Nibble

Removes (“nibbles”) a polygonal area from the selected objects in the active cell,
using the Box, 45° Polygon, 90° Polygon, or Wire tools. Nibble outlines are
drawn on the Drag box layer. (See Setup > Special Layers  for information on
the Drag box and other special layers.) When one of the Wire tools is used to
nibble, the width of the nibbled area is the wire width specified for the Drag box
layer. (See Setup > Layers  for information on wire settings.)

Draw Menu



C o m m a n d  R e f e r e n c e D r a w  >  S l i c e  >  H o r i z o n t a l

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Draw > Slice > Horizontal

Divides the selected objects in the active cell along a horizontal line. The location
of the axis is determined with the pointer. If all of the selected objects are not
visible at the current zoom level, the command zooms the display to include the
selections.

Draw Menu



C o m m a n d  R e f e r e n c e D r a w  >  S l i c e  >  V e r t i c a l

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Draw > Slice > Vertical

Divides the selected objects in the active cell along a vertical line. The location of
the axis is determined with the pointer. If all of the selected objects are not visible
at the current zoom level, the command zooms the display to include the
selections.

Draw Menu



C o m m a n d  R e f e r e n c e D r a w  >  M e r g e

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Draw > Merge

Merges intersecting selected objects into a single object. The selection may
include non-intersecting objects and objects on multiple layers; however, only
sets of intersecting objects on a single layer are merged into single objects.

All-angle objects (polygons and wires) cannot be merged with other objects.

Draw Menu



C o m m a n d  R e f e r e n c e D r a w  >  G r o u p

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Draw > Group

Opens the Group  dialog and creates a new cell containing the selected objects
and instances that cell in the active cell. Any type of object (geometry, ports,
instances) may be grouped. The command can also be used to create an array
from selected instances of the same cell with regular translations and
transformations.

Draw Menu

Group Cell Name The name of the new cell.

Cell info Includes Author , Organization , and 
Information  (notes or messages) for the new 
cell.



C o m m a n d  R e f e r e n c e D r a w  >  U n g r o u p

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Draw > Ungroup

Flattens the selected grouped instances into their component instances or cells.
When used on an array, the command “explodes” the array into its component
instances.

Draw Menu



C o m m a n d  R e f e r e n c e D r a w  >  P i c k  L a y e r

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Draw > Pick Layer

Changes the current layer to the layer of the selected object. If multiple objects
are selected, the current layer changes to the layer of the last object selected in
the sequence (excluding instances). If no objects are selected, the current layer
changes to the layer of the object closest to the cursor. If the cursor is over or near
an instance, L-Edit checks inside the instance for the closest object.

Draw Menu



C o m m a n d  R e f e r e n c e C e l l  >  N e w

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Cell > New

Opens the Create New Cell  dialog. The newly created cell becomes the active
cell.

Cell Menu

New cell name The name of the new cell. Each component cell 
of a file must have a unique name.

Cell info Includes Author , Organization , and 
Information  (notes or messages) for the active 
cell.

Open in new window When this box is checked, the cell will open in 
a new layout window. Changing the state of the 
same box in the Select Cell To Edit dialog (see 
Cell > Open ) changes the state of this box. The 
last state of the check box is saved when L-Edit 
is closed.



C o m m a n d  R e f e r e n c e C e l l  >  O p e n

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Cell > Open

Opens the Select Cell To Edit  dialog.

Cell Menu

File The name of the active TDB file (default). All 
open TDB files are listed in the drop-down list.

Cell The specified file’s component cells are 
displayed in the scrollable list. Highlight a cell 
by clicking its name in the scrollable list, then 
double-click or click OK to open the cell.

Open in new window When this box is checked, the cell will open in 
a new layout window. Changing the state of the 
same box in the Create New Cell  dialog (see 
Cell > New ) changes the state of this box. The 
last state of the check box is saved when L-Edit 
is closed.



C o m m a n d  R e f e r e n c e C e l l  >  C o p y

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Cell > Copy

Opens the Select Cell To Copy  dialog. Cells may be replicated within a file or
copied from one file to another. All instances and primitives are copied and the
new cell becomes the active cell. The new cell must have a unique name.

Clicking OK opens the Cell Copy  dialog.

Cell Menu

File The name of the active document (default). All 
open TDB files are listed in the drop-down list.

Cell The specified file’s component cells are 
displayed in the scrollable list. Highlight a cell 
by clicking its name in the scrollable list, then 
double-click or click OK to copy the cell and 
open the Cell Copy  dialog.

Cell copy’s name The name of the copy. Each cell in a file must 
have a unique name.



C o m m a n d  R e f e r e n c e C e l l  >  R e n a m e

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Cell > Rename

Opens the Rename Cell [cell name]  dialog.

Cell Menu

Rename cell as The new name of the active cell.

Cell info Includes Author , Organization , and 
Information  (notes or messages) for the active 
cell. Text fields can be edited.



C o m m a n d  R e f e r e n c e C e l l  >  D e l e t e

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Cell > Delete

Opens the Select Cell To Delete  dialog. Only cells which are not instanced in
other cells can be deleted.

Cell Menu

File The name of the active TDB file (default). All 
open TDB files are listed in the drop-down list.

Cell The specified file’s component cells are 
displayed in the scrollable list. Cells which 
cannot be deleted (due to being instanced in 
other cells) have a red (x) next to them. 
Highlight an available cell and click OK to 
delete the cell.

Hierarchical delete Checking this box causes all cells instanced 
within the selected cell to also be deleted, 
unless they are instanced in additional cells.



C o m m a n d  R e f e r e n c e C e l l  >  R e v e r t  C e l l

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Cell > Revert Cell

Returns the active cell to its last saved state. All changes made since that time are
discarded and cannot be recalled with the Edit > Undo  command. A warning
prompts you to confirm the operation.

Cell Menu



C o m m a n d  R e f e r e n c e C e l l  >  C l o s e  A s

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Cell > Close As

Opens the Close Cell As  dialog. Closes the edited active cell as a new cell.

Cell Menu

Make cell with current edits 
into new cell with name

The new name of the edited cell.



C o m m a n d  R e f e r e n c e C e l l  >  I n s t a n c e

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Cell > Instance

Opens the Select Cell To Instance  dialog and instances a cell in the active cell.

Cell Menu

File The name of the active document (default). All 
open documents are listed in the drop-down 
list.

Cell The specified file’s component cells are 
displayed in the scrollable list. Highlight a cell 
and click OK or double-click to instance the 
cell.



C o m m a n d  R e f e r e n c e C e l l  >  I n s t a n c e

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Replace Enabled only when an instance in the Layout 
Area is selected. When the Replace  box is 
checked, the selected instance is replaced with 
an instance of the new cell. There are two 
replacement options: Abutment  matches the 
new instance with the Abut ports in the cell, 
designated in the Setup > SPR  dialog. Origin  
places the origin of the new instance at the 
origin of the instance being replaced. The 
translation of the new instance is the same as 
the instance being replaced. (See Edit 
Object(s) – Instances  for information on 
Translation .)



C o m m a n d  R e f e r e n c e C e l l  >  F l a t t e n

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Cell > Flatten

Flattens the hierarchy in the active cell. All instances in the current cell —
including instances within instances — are replaced by the instance’s contents. A
warning prompts you to confirm the operation. This command is irreversible.

Cell Menu



C o m m a n d  R e f e r e n c e C e l l  >  F a b r i c a t e

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Cell > Fabricate

Opens the Select Cell to Fabricate  dialog. A cell can be selected to be tagged for
foundry fabrication in conformity to CIF conventions for specifying the design
cell to be fabricated. By convention, the fabrication tag is placed on a single cell
at the topmost level of the design. An (F) to the left of the cell name in the Cell
Browser designates a cell as tagged for fabrication.

Cell Menu

File The name of the active TDB file (default). All 
open TDB files are listed in the drop-down list.

Cell The specified file’s component cells are 
displayed in the scrollable list. Highlight a cell 
and click OK to tag the cell.



C o m m a n d  R e f e r e n c e C e l l  >  I n f o

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Cell > Info

Opens the Cell Information dialog and displays information for the active cell.

Cell Menu

Cell name The name of the active cell.

Cell data Includes Author , Organization , and 
Information  (notes or messages) for the active 
cell. Text fields can be edited.

Cell lock Toggles locking of the cell contents. Locked 
cells cannot be edited, but they can be 
instanced in other cells and their content can be 
copied.

Cell version and dates The date and time the cell was created and last 
revised. The version numbering system 
provides an internal accounting method for 
tracking changes. Major numbers are increased 
by clicking the Increment  button; minor 
numbers are automatically incremented each 
time changes in the cell are saved.



C o m m a n d  R e f e r e n c e S e t u p  >  P a l e t t e

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Setup > Palette

Opens the Setup Palette  dialog which prompts for modifications to the color
palette. The palette contains 16 colors, each with two attributes: a unique 4-bit
identifying code and the “amounts” of the color’s three components (red, green,
and blue).

Setup Menu

(4-bit codes) The numbers from 0 to 15 are represented by 4-
bit codes (filled=1, empty=0; for example, 

 = 1011 = 11). Each code is associated 
with a color, which can be changed.



C o m m a n d  R e f e r e n c e S e t u p  >  P a l e t t e

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Color (RGB) Click a sample bar or code on the left side of 
the dialog to display its composition on the 
right side as a function of the three components 
(red, green, and blue). Each component takes 
one of 256 levels. Thus, L-Edit’s 16 colors can 
be chosen from a pool of 16 million 
possibilities. To change the level of a 
component, move the slider of the desired 
color or type the desired level (0–255) in the 
text field at the bottom of the sliding control.



C o m m a n d  R e f e r e n c e S e t u p > A p p l i c a t i o n

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Setup > Application

Opens the Setup Application  dialog which prompts for changes to
application-wide settings.

Setup Menu

Configuration files ASCII files containing application-wide setup 
information that can be edited and shared 
among multiple users. When both Workgroup  
and User  (personal) files are specified, settings 
from the User  file override settings in the 
Workgroup  file. Any changes made to the 
application-wide parameters in the Setup 
Application  dialog (listed below) are saved to 
the User  file.

To load settings from an existing file, enter the 
name of the file in the Workgroup  or User  
field or choose from available files with the 
Browse  button next to the desired field. Click 
Load  to load the settings into L-Edit.



C o m m a n d  R e f e r e n c e S e t u p > A p p l i c a t i o n

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

The Setup Application  dialog contains two tabs:

� General

� Keyboard

To save settings to a new or existing file, enter 
the name of the file in the User  field or choose 
from available files with the Browse  button 
next to the User  field. Click OK to save the 
settings to the file.
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Setup Application – General

Active-push 
rubberbanding

If this box is checked, the mouse button does 
not need to be held down during a drag. For 
example, when drawing a box you can click 
and release the Draw button at one corner of 
the box, move the pointer to the opposite 
corner of the box, then click the Draw button 
again to complete the operation.

Paste to cursor If this box is checked, the contents of the paste 
buffer appear in the Work Area when the 
Edit > Paste  command is executed but move 
with the pointer until any mouse button is 
clicked. They are then “dropped” into place at 
the location of the pointer. Before they are 
“dropped,” the objects may be rotated or 
flipped from the keyboard (see Draw > Rotate , 
Draw > Flip > Horizontal , Draw > Flip > 
Vertical ).

Auto-panning If this box is checked, L-Edit automatically 
pans the view when the pointer touches an edge 
of the Work Area during a draw, move, or edit 
operation.



C o m m a n d  R e f e r e n c e S e t u p > A p p l i c a t i o n

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Hide instance insides if 
less than

Two parameters define the minimum size (in 
pixels) that an instance must have to be drawn 
to the screen. If the width of the instance is 
smaller than the Horizontal  parameter or the 
height of the instance is smaller than the 
Vertical  parameter, the instance is drawn in 
outline mode (its insides are not shown). 
Suppressing the display of instances can not 
only enhance screen redraw times but also 
serves to clarify the layout if the screen is 
zoomed out to a relatively small magnification.

Layer icon size Controls the pixel size of the icons on the 
Layer Palette.

Drawing mode Sets the default display of drawing tools on the 
Drawing Bar. When Orthogonal  or 45 
Degrees  is chosen, only those tools fitting that 
description will be displayed. When All Angle  
is selected, all tools are displayed. 

Use large buttons Checking this box increases the size of all 
toolbar buttons by 50 percent.

Recently used file list Controls the number of recently used files 
displayed in the File  menu. (See File > 
(recently used files) .
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Setup Application – Keyboard

TDB setup path Predefined directories for TDB setup files. 
TDB files in these directories are listed in the 
Copy TDB setup from file field in the File > 
New and File > Import Mask Data  dialogs.

Category Command categories corresponding to L-Edit 
menu items. To select a category, highlight an 
item in the drop-down list.

Editor L-Edit contains two editors that correspond to 
the two available file types: Layout  and Text . 
(See File > New  for information on file types.) 
Each editor contains its own set of commands 
and shortcuts. To remap shortcut keys for a 
specific editor, select the desired choice from 
the drop-down list.

Commands The set of commands for the selected category. 
Highlight a command from the list to select it. 
Additional commands may be viewed by 
moving the scrollbar up or down.

Description A description of the command highlighted in 
the Commands  list.



C o m m a n d  R e f e r e n c e S e t u p > A p p l i c a t i o n

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Current keys The current shortcut key combination for the 
command highlighted in the Commands  list. 
To delete a shortcut, highlight the shortcut and 
click the Remove  button.

Press new short key With the cursor in the field, press the desired 
shortcut on the keyboard, which will then be 
textually represented in the field. Click the 
Assign  button to register the new shortcut.

Default Reassigns shortcut key assignments in the 
current editor to their default settings.
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Setup > Design

Opens the tabbed Setup Design  dialog and prompts for file-specific editing
options.

The Setup Design dialog contains four tabs:

� Technology

� Grid

� Selection

� Drawing

Setup Menu
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Setup Design – Technology

Technology name Used by L-Edit to determine whether two 
design files are compatible. If you attempt to 
copy a cell from a file with a technology name 
different from that of the current cell, a 
warning is presented.

Technology units A technology is characterized by a specific unit 
of measurement. Select one of the predefined 
units (Microns , Mils , Millimeters , 
Centimeters , or Inches ), or a custom unit 
(Other ). If you choose a custom unit then you 
must also specify its equivalent in microns and 
in Internal Units (for CIF/GDS II output, 
design rule checking, and other purposes) in 
the Technology setup  group.

Maintain physical size of all 
objects

Changes the Internal Units to reflect the 
relationship between physical units and 
Internal Units.

Rescale the design Rescales the mapping of physical units to 
Internal Units.

Technology setup The relationships defined for a custom unit 
with Internal Units and with microns.
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For example, you might choose to define one 
Internal Unit as one foot (= 12 inches Ý 
304800 microns). Under Technology units , 
click Other  and enter “Foot” as the name of the 
unit. Then, under Technology setup , define 1 
Internal Unit =  1⁄ 1 Foot  and 1 Foot =  
304800⁄ 1 Microns .
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Setup Design – Grid

Displayed grid The absolute spacing, in Locator Units, of the 
displayed grid. The value entered in this field is 
the length of a grid square side.

Suppress grid less than The apparent spacing of the displayed grid 
varies with the magnification of the Work 
Area. If the number of screen pixels per grid 
square side falls below the value entered in this 
field, then the grid is hidden.

Cursor type Snapping  sets the only possible positions of 
the pointer to be at the mouse snap gridpoints. 
Smooth  sets the pointer’s position to be 
unconstrained.

Mouse snap grid The absolute spacing, in Locator Units, of the 
mouse snap grid. The value entered in this field 
is the length of a grid square side.

One Locator Unit The value entered in this field is the number of 
internal units equivalent to one Locator Unit. 
Locator Units are used by the coordinate 
system of the Layout Area.
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Setup Design – Selection

Selection range A positive integer S such that: if the pointer is 
outside an object but is still within S Locator 
Units of any of the object’s edges, then the 
object can still be explicitly, implicitly, or 
cyclically selected.

When multiple objects are within the selection 
range, L-Edit determines which object to select 
using the following priority: (1) objects the 
pointer is inside, ordered by the closest edge; 
(2) objects the pointer is outside, yet still 
within the selection range, ordered by the 
closest edge.

Deselection range A positive integer D such that: if a mouse 
button is clicked (for example, to initiate a 
move, edit, or copy operation) when the 
distance between the pointer and a selected 
object is greater than D Locator Units, then the 
selected object is deselected before the 
operation is performed. By default the 
deselection range is set to the largest possible 
number (to indicate infinity) so that a selected 
object is never automatically deselected.
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Setup Design – Drawing

Edit range A positive integer E such that: if the pointer is 
within E internal units of an edge or vertex of a 
selected object, then an operation with the 
MOVE/EDIT button is an edit; otherwise it is a 
move. Two numbers are supplied: one in 
Locator Units , the other in Pixels . E takes the 
value that is larger on-screen at any given time.

Select drawn objects If this box is checked, L-Edit automatically 
selects an object after it is created. This is 
useful for designers who like to position or edit 
objects after creating them, rather than while 
drawing them.

Default port text size The default letter height, in Locator Units, for 
text associated with ports. Changing this value 
affects all subsequently created ports; those 
created previously are not affected.

Nudge amount The default distance, in Locator Units, that an 
object moves during a nudge operation.



C o m m a n d  R e f e r e n c e S e t u p  >  D e s i g n

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Default ruler settings: The default text and tick mark settings for the 
ruler. Changing these values affects all 
subsequently created rulers; those created 
previously are not affected.

Text size The default letter height, in Locator Units, for 
text associated with rulers.

Display text Ruler text can be displayed in one of four 
ways: No text , Centered , At end points , or At 
tick marks . Select the desired option from the 
drop-down list.

End style Ruler lines contain one of two end styles: 
arrows or tick marks. Highlight the illustration 
in the drop-down list to select the default end 
style.

Show tick marks Toggles the display of tick marks. To change 
the position of Major  and Minor  tick marks (in 
Locator Units), type the desired spacing in the 
appropriate field. Major  tick marks are twice as 
long as Minor.

Symmetric When this box is checked, tick marks are 
symmetrical around the ruler line.
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Create rulers on The default layer for rulers. The Current Layer  
option places rulers on whichever layer is 
currently selected on the Layer Palette. To set 
rulers to a specific layer, click the second 
option button and select a layer from the 
drop-down list.
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Setup > Layers

Opens the Setup Layers  dialog and prompts for modifications to the layer
structure of the active file. L-Edit supports an unlimited number of layers; each
layer contains three pass lists; each pass list consists of any number of separate
passes.

Setup Menu

Layers The list of layers in the active file. To add a 
layer to the list, click the Add layer button. A 
New Layer [n] (where [n] is the number of the 
new layer) is highlighted and can be edited. 
Two layers cannot have the same name and 
generated layers must be entered in the list 
after the layers from which they are derived. 
Layers can be repositioned in the list by 
clicking the up or down Move Layer  arrow.

To delete a layer, highlight the layer in the list 
and click Delete layer . A layer can only be 
deleted if it contains no geometry.
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The Setup Layers  dialog contains three tabs: 

� General

� Derivation

� Rendering

Layer name The name of the highlighted layer in the 
Layers  list. This field can be edited.
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Setup Layers – General

Locked When this box is checked, geometry on this 
layer cannot be drawn, moved, or edited.

Hidden When this box is checked, the layer is hidden 
(not displayed).

Layer-to-substrate 
capacitance

Specify the Area  and Fringe  capacitance 
between the layer and the substrate.

Resistivity Specify the resistivity (resistance per square 
unit area) of the layer material in Ohms/square.

Import/Export To edit the import/export parameters of the 
selected layer, enter values in the GDSII 
number  and CIF name  fields.

Default wire settings Set the default Width  (in Locator Units), End 
style , and Join style  for the layer’s wire 
settings. (See Wire Styles for more information 
on wire settings.)
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Setup Layers – Derivation

Enable Derivation When this box is checked and source layer 
information (below) is entered, the named 
layer is generated as a generated layer. 
Checking or unchecking this box is a 
convenient way to activate or deactivate the 
generation of a particular derived layer without 
needing to change other setup information.

Source layers (Locator 
Units)

Existing layers from which the new layer will 
be created (derived). Up to three source layers 
can be selected.

NOT When this box is checked, the source layer is 
specified as a NOT operation.

Grow Enter a positive or negative integer for the 
amount, in locator units, by which objects on 
the source layer are grown or shrunk on the 
derived layer. The size of the object is changed 
by expanding or decreasing each side by the 
specified number of units.

Layer 1... Layer 2... Layer 3 Select each source layer from the drop-down 
list. Only layers listed prior to the target layer 
are available.
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Setup Layers – Rendering

Operation Select AND or OR from the drop-down lists 
between Layer 1  / Layer 2  and Layer 2 / Layer 
3 to specify pairwise operations. For example, 
if Layer 1  is Poly and Layer 2  is Active, 
choosing AND between them results in Poly & 
Active for the derived layer.

Pass list Select the type of pass list to edit in the drop-
down list: Object , Port , or Text . (See Pass 
Lists for more information on pass types.)

The list below the Pass list  drop-down list 
contains the Pass , Color-Plane , Write-Mode , 
and Stipple  of the pass. To edit a pass, 
highlight it in the list. To add a pass to the list, 
click the Add pass button. A new pass is 
highlighted and can be edited. To delete a pass, 
highlight the pass in the list and click Delete 
pass . (For more information on passes and 
their attributes, see Pass Lists.)
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Color To change the color of the pass, click one of 
the sample bars or 4-bit codes in the drop-down 
list.

Mode To change the write-mode of the pass, select 
Set or Clear  from the drop-down menu.

Stipple To change the stipple of the pass, click one of 
the pattern buttons surrounding the stipple edit 
box, or edit the pixel pattern in the stipple edit 
box directly.
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Setup > Special Layers

Opens the Setup Special Layers  dialog and assigns special layers. To select a
layer for each option, highlight a layer from the option’s drop-down list.

Setup Menu

Grid The layer on which the displayed grid points 
are drawn.

Drag box The layer on which the boxes displayed during 
a drag operation are drawn.

Origin The layer on which the origin crosshair marker 
is drawn.

Cell outline The layer on which instanced cell outlines are 
drawn.

Error The layer on which DRC and SPR error 
markers are drawn.

Icon The layer on which nonfabricated comment 
items are drawn.
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First mask The layer in the top left corner of the Layer 
Palette.
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Setup > DRC

Opens the Setup Design Rules  dialog and prompts for modifications of design
rules.

Setup Menu

Rule set Name identifies the design rule set. Tolerance  
is a value T, common to all rules in the set, 
which together with the distance D for each 
rule (see below) determines the precision of 
error checking. A distance on the layout must 
be outside the range D±T to be flagged as a 
violation. A minimum tolerance of 5 internal 
units is required for designs containing 45° 
geometry. The tolerance may be set to zero for 
pure orthogonal designs.
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Rules list The list of available rules. To add a new rule, 
click the Add rule  button and type the name of 
the new rule in the Rule  field. To delete a rule 
highlight the rule and click the Delete rule  
button. Rules can be repositioned in the list by 
highlighting the rule and clicking the up or 
down Move Rule  arrows.

Rule The name of the rule highlighted in the Rules 
list . Rule type , Ignore , Rule distance , and 
Rule layers  all pertain to the uniquely named 
rule.

Enable If this box is checked, the rule will be checked 
when DRC is run. If violations are detected, the 
names of the violated rules are indicated.

Rule type Selected by clicking the appropriate option 
button. See Design Rule Types for information 
on the seven supported types. 

Ignore Cases which will not be considered a design 
rule violation. See Rule Exceptions for 
information on how minimum width, spacing, 
and surround rules can be fine-tuned by 
checking these boxes.
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Write to file

This button opens the Write DRC Rules to File  dialog, which prompts for the
name, path (location), and type (extension) for the text file. There is one
predefined file type: .rul.

Rule distance The distance value associated with a rule. 
Distances are measured either in Locator Units 
or in user units. (User units are defined with the 
command Setup Design – Technology .)

Rule layers DRC specifies which layers are involved in 
each of the design rules. For example, selecting 
the Spacing  rule type automatically specifies 
Minimum Layer [ ] to Layer [ ] spacing . The 
appropriate layers can be selected from the 
drop-down menus.
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Setup > SPR

Opens the SPR Setup  dialog and prompts for modifications to parameters for
standard cell place and route.

Setup Menu

Standard cell library file Contains the standard cells and pad cells that 
will be used to generate the components of the 
design. Enter the full pathname if the file is not 
in the current L-Edit directory.

Netlist file The Tanner Place and Route (TPR) netlist file 
of the circuit. This is a textual description of 
the schematic design and identifies which cells 
are required from the standard cell library. It 
can be produced by S-Edit or a SPICE netlist 
can be converted to TPR with a conversion tool 
such as NetTran. The netlist file is not required 
if only padframe generation is performed.
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There are three buttons associated with SPR setup:

� Core setup  — prompts for modifications to core setup parameters.

� SPR Padframe Setup  — prompts for modifications to padframe setup
parameters.

� SPR Pad Route Setup  — prompts for modifications to pad route setup
parameters.

Each tab in each dialog contains a Reset  button, which will reset all fields and
options to the values they held when you accessed the tab.

SPR Core Setup

The SPR Core Setup  dialog consists of five tabs:

� General

� Layers

� Design Rules

Power/Ground node names The schematic netlist names of the Power 
signal  and the Ground signal  must match the 
names of the power and ground ports in the 
standard cells.
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� I/O Signals

� Global Signals

SPR Core Setup – General

L-Edit requires three special standard cells in a library set: a row crosser cell, the
tie-to-power cell, and the tie-to-ground cell. They are used for node connections
only and are not included in the TPR netlist.

Row crosser cell  A row crosser cell contains one row cross port 
and is placed to make up a cross-row pass to 
route wires across a standard cell.

Tie-to-Power cell The tie-to-power cell is needed where a TPR 
standard cell has a pin directly tied to Vdd.

Tie-to-Ground cell The tie-to-ground cell is needed where a TPR 
standard cell has a pin directly tied to Gnd.

Row crosser port The name of a row crosser port. A row crosser 
port is used to identify crossing paths to route 
wires across a standard cell row.

Abutment port The name of an abutment port in a standard 
cell. L-Edit uses the abutment port for precise 
positioning of a cell.
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Core cell The name of the core cell to be created.

Row cell The name of the row cells to be created.

Channel cell The name of the channel cells to be created.
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SPR Core Setup – Layers

Signal routing layer 
assignment

Choose the Horizontal  (for signals running left 
and right), Vertical  (for signals running up and 
down), and Contact  signal routing layers by 
highlighting the desired layer in the drop-down 
list. Overlap capacitance  values are 
calculated automatically using the 
Layer-to-substrate capacitance  entered in the 
Setup Layers – General  dialog. This 
information is required if the Write nodal 
properties file  option in the Standard Cell 
Place and Route  dialog is checked.

Power/Ground routing 
layer assignment

Choose the routing layer assignment for power 
and ground by highlighting the desired layer in 
the drop-down list.

Layer-to-layer area 
capacitance

Enter the Horizontal to vertical layer  
capacitance. This entry is required if the Write 
nodal capacitance file  option in the Standard 
Cell Place and Route  dialog is checked. The 
units of capacitance should be the same as 
those used in the simulation file and can be 
obtained from your chip foundry.
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SPR Core Setup – Design Rules

Wire/contact width Minimum wire width of horizontal and vertical 
routing segments and minimum width of 
contacts (vias).

Layer spacing Hotizontal layer  and Vertical layer  define the 
minimum distance between two routing 
segments or contact surrounds in the horizontal 
and vertical layers. Contact defines the 
minimum spacing between neighboring 
contacts (vias).

Layer - Cell spacing The minimum distance between standard cells 
and routing segments or contact surrounds in 
the horizontal and vertical layers.

Contact surround The width of contact surrounds in the 
horizontal and vertical layers.

Cell - Cell spacing The minimum distance between two standard 
cell rows.

Cell - Power spacing The minimum distance between the Vdd  and 
Gnd  rails and the outermost standard cells in 
each row.
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SPR Core Setup – I/O Signals

Power (Vdd) rail on Power and ground can be run on either the Left 
side  or the Right side  of the cell. Click the 
option button to select a side. The Vdd side is 
overriden by the location of the Vdd pad on the 
padframe if there is a conflict.

I/O signals leave core on Click the option button for which layer I/O 
signals should leave the core on: Horizontal 
layer  or Vertical layer .

I/O signal list This list defines the names of the signals 
leaving the core and the side from which they 
exit. The signals must be ordered according to 
the side from which they exit the core: Upper 
left, then bottom, then right, then top. 

To add a signal to the list, click the Add  button. 
A New Signal  is highlighted and can be edited. 
The name of the signal must be the same as in 
the netlist or schematic. To delete a signal, 
highlight the signal in the list and click Delete .

The I/O Signal list  is only required for a 
separate core place and route.
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SPR Core Setup – Global Signals

Global input signal names 
in netlist

Specify the names of one or two signals for 
global routing.

Port names in standard 
cells

The names of the ports to be used for each 
global input signal. These port names 
subsequently define the bus, rail, and pad 
positions used to route each global signal net.

Buffer cells in standard cell 
library

Type the names of the Buffer cell left side and 
Buffer cell right side for the standard cell 
rows. If the design has only a single global 
input signal, specify one buffer cell on the 
same side as the global input signal rail.

Driving force  is the driving capability (fanout) 
of one buffer cell — the maximum number of 
standard cells that can be driven by this buffer 
cell. The value must be greater than or equal to 
1. L-Edit uses this value to calculate the 
number of buffer cells to place on the edge of 
each row.
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SPR Padframe Setup

The SPR Padframe Setup  dialog consists of two tabs:

� General

� Layers

Global input signal rail 
positions

Click the option button for whether the Global 
input signal 1 rail  should be on the Left side  
or the Right side . The rail for signal 2 will be 
placed on the opposite side.
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SPR Padframe Setup – General

SPR Padframe Setup – Layers

Library cells Specify the name of the Power pad cell , the 
Ground pad cell , and the Corner pad cell  to 
be drawn from the standard cell library.

Port names Enter the name of the port that defines the edge 
of each pad cell in the Pad cell abutment port  
field. In the Pad cell mirror port  field, enter 
the name used in the standard cell library to 
designate mirror ports in pad cells. L-Edit 
places pad cells with this port name in a special 
orientation. Enter the name of the port that 
defines the inner edge of the padframe in the 
Padframe port  field.

Output cell name Specify the name of the Padframe cell .

Padframe dimensions 
(Locator Units)

Specify the Width  and Height  of the padframe 
in Locator Units. If you enter zero for either or 
both dimensions, L-Edit automatically 
determines the minimum size required.
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Padlist A numbered list of pads and their attributes. If 
the padlist is empty, the pad configuration in 
the netlist will be used. If the padlist contains a 
padframe specification, L-Edit asks if the 
padframe should be generated using the padlist 
or the pad configuration in the netlist.

To add an instance to the list, click the Add  
button. A New Pad  is highlighted and can be 
edited. To delete a pad, highlight it by clicking 
any of its attributes and click Delete .

# The number of the pad in the padframe. L-Edit 
orders pads counterclockwise along each side 
according to this number.

Instance name The name of the pad instance. The name of the 
pad must be the same as the instance name in 
the netlist file. Pad cell names can be entered if 
no netlist is provided. (Padframe generation 
only.)

Side The side of the padframe on which the pad is 
placed. Pads must be entered into the list in 
order: Left, then bottom, then right, then top.
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SPR Pad Route Setup

The SPR Pad Route Setup  dialog consists of five tabs:

� General

� Layers

� Design Rules

� Core Signals

� Padframe Signals

Mirror When this column specifies Yes for a given 
pad, the pad will be mirrored through its 
vertical axis — unless this will conflict with 
information present in the standard cell library. 
This column is used for pad placement at 
specific locations and orientations.

Power/Ground Enter Vdd and Gnd to designate particular pads 
as power and ground. Only one of each pad 
may be placed. (See SPR Padframe Setup if 
more than one power or ground pad is required 
in your design.)
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SPR Pad Route Setup – General

SPR Pad Route Setup – Layers

SPR Pad Route Setup – Design Rules

Output cell name Specify the name of the Chip cell . The chip 
cell contains the core and the padframe 
instance, and is where the pad routing will be 
placed.

Pad routing layer 
assignment

Choose the I/O signal layer and Power/
Ground layer  by highlighting the desired layer 
in the drop-down list. I/O signals and power/
ground signals must be routed in different 
layers. I/O signals must be assigned to the 
same layer as what is specified in the SPR 
Core Setup – I/O Signals  dialog.

Wire width Minimum wire width of I/O signals.
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Layer spacing The minimum distance between two routing 
segments in the I/O signal routing layer and the 
power/ground routing layer.

Layer - Core spacing The minimum distance between the core cell 
and any routing segment in the I/O signal 
routing layer and the power/ground routing 
layer.

Layer - Pad spacing The minimum distance between the pad cells 
and any routing segment in the I/O signal 
routing layer and the power/ground routing 
layer.
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SPR Pad Route Setup – Core Signals

SPR Pad Route Setup – Padframe Signals

I/O signal list Defines the names of all signals exiting or entering 
the core, beginning with the first signal on the 
upper left side of the core and proceeding counter-
clockwise. Edit the Signal name , Side , or Connect  
(Yes or No) by highlighting the item and typing the 
desired value.

To add a signal to the list, click the Add  button. A 
New Signal  is highlighted and can be edited. To 
delete a signal, highlight it by clicking any of its 
attributes and click Delete .

This list can be left empty if you perform pad route 
in conjunction with core place and route.

I/O signal list Defines the names of all signals exiting or entering 
the padframe, beginning with the first signal on the 
upper left side of the padframe and proceeding 
counterclockwise. Edit the Signal name , Side , or 
Connect  (Yes or No) by highlighting the item and 
typing the desired value.
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To add a signal to the list, click the Add  button. A 
New Signal  is highlighted and can be edited. To 
delete a signal, highlight it by clicking any of its 
attributes and click Delete .

This list can be left empty if you perform pad route 
in conjunction with core place and route and 
padframe generation.
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Tools > Clear Rulers

Opens the Delete Rulers  dialog and prompts for options, then removes all rulers
from the current cell, the current file, or all open files. This command cannot be
undone.

Tools Menu

This Cell ( cell name ) Removes rulers in the active cell.

This File ( file name ) Removes rulers in the active file.

All Files Removes rulers in all open files.
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Tools > Generate Layers

Opens the Generate Layers  dialog, prompts for options, then creates generated
Boolean layers defined with the Setup > Layers  command. All objects on
existing generated layers are cleared automatically before new ones are
generated.

Note: Tools > Generate Layers  only operates on boxes and 45°/90° polygons and
wires. Objects are not created on layers generated from circles or all-angle
objects.

Layers are generated inside the minimum boundary of the active cell, defined by
the outer edge of the outermost objects. In other words, a NOT operation on an
object will not result in a huge polygon which spans the entire Layout Area;
instead, the created object will be as large as the area including all existing
objects, and an extra amount to account for the Grow  operation. Generated
objects are placed directly into the active cell. They are the same as other L-Edit
objects and can be edited.

Tools Menu
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Warning: When the Generate Layers  command is executed, objects previously drawn on
generated layers will be deleted.

During generation, a dialog displays which layer is currently being generated and
the status of the overall process.

Target The layer to be generated is selected from the 
Layer  drop-down list. If any of the selected 
layer’s source layers are generated layers, then 
those layers are recursively generated as well. 
Alternatively, All Layers  may be generated at 
once.
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Binning L-Edit divides the layout into a grid of square 
bins and performs layer generation within each 
bin. Choosing the optimal bin size significantly 
increases performance because objects which 
are very distant from one another are not 
involved together in layer-generation 
operations. Bin size  is the length (in Locator 
Units) of one side of a bin. If the Merge 
objects after generation box is checked, 
intersecting objects on the same generated 
layer are merged after all layers have been 
generated. (See Draw > Merge  for more 
information on merging layers.) 
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Tools > Clear Generated Layers

Opens the Delete Objects on Generated Layers  dialog and prompts for options,
then removes all generated layers from the current cell, the current file, or all
open files. All objects on those layers are deleted, regardless of how they were
created. This command cannot be undone.

Tools Menu

This Cell ( cell name ) Removes generated layers in the active cell.

This File ( file name ) Removes generated layers in the active file.

All Files Removes generated layers in all open files.
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Tools > DRC

Opens the Design Rule Check  dialog, prompts for options, then checks the
layout for design rule violations. DRC only operates on boxes and on 45°/90°
polygons and wires; it cannot check for design rule violations on circles or
all-angle polygons and wires.

Clicking the Setup  button opens the Setup Design Rules  dialog (see Setup >
DRC).

Tools Menu

Place error ports When this box is checked, an error port is 
placed at the location of each violation. An 
error port consists of the name of the violated 
design rule and a bracketed expression; the 
expression indicates the spacing or nature of 
the error and the rule distance.

Place error objects When this box is checked, marker objects are 
placed at the locations of violations.
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Write errors to file When this box is checked, errors are written to 
a text file. The default name of the file is 
cell .drc , where cell  is the name of the current 
cell. This file can be read with any text editor.

Bin size DRC performs a check of the entire cell. The 
layout is divided into a grid of square bins. The 
Bin Size  is measured in locator units. The 
entire cell check is performed bin-by-bin, 
beginning in the lower left corner of the layout 
and moving to the right. When the right edge is 
reached, L-Edit moves up to the next row, 
beginning again on the left. Thus two objects 
placed relatively far apart will never be 
checked for design rule correctness. This poses 
no danger, since objects far apart always 
satisfy any applicable spacing rules.

When each bin is completed, it is marked with 
a large × from corner to corner if a design rule 
violation was discovered within its boundaries. 
When the whole check is completed, L-Edit 
displays the total number of errors detected.
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Tools > DRC Box

Checks a specified area in the layout for design rule errors. Use the DRAW
mouse button to drag a rectangular region surrounding the layout to be checked
(this region is represented by a box on the Error layer). When the DRAW mouse
button is released, the Design Rule Check  dialog appears (see Tools > DRC ).

Tools Menu
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Tools > Clear Error Layer

Opens the Delete Objects on Error Layer  dialog, prompts for options, then
removes all objects on the Error layer from the current cell, the current file, or all
open files. This command cannot be undone.

It is not necessary to run Clear Error Layer  before running DRC. DRC
automatically clears the Error layer in the active cell and in its instanced cells as
its first step.

Tools Menu

This Cell ( cell name ) Removes all objects on the error layer in the 
active cell.

This File ( file name ) Removes all objects on the error layer in the 
active file.

All Files Removes all objects on the error layer in all 
open files.
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Tools > Place and Route

Opens the Standard Cell Place and Route  dialog. Clicking the Setup  button
opens the SPR Setup  dialog (see Setup > SPR ).

Tools Menu

Core place and route When this box is checked, L-Edit runs the core 
place and route module.

Padframe generation When this box is checked, L-Edit runs the 
padframe generation module.

Pad route When this box is checked, L-Edit runs the pad 
router module.

Global input signal routing When this box is checked and Core place and 
route  is run, L-Edit performs a separate global 
route of up to two input signal nets. (For more 
information see SPR Core Setup – Global 
Signals.) 
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Placement The Optimization  option instructs L-Edit to 
analyze the design in order to reduce its overall 
area. When this option is off, L-Edit places 
cells according to their sequence in the netlist.

The Optimization factor  controls the degree of 
optimization and thus the quality of the 
placement. The higher the value, the greater the 
total placement time.

Configuration Grid  is the side of a square of the grid on which 
the placement optimizer and channel router 
operate. Typically, this value is equal to the 
port grid within the standard cells.

Number of rows  in the finished core. If zero is 
entered, L-Edit computes the actual number of 
rows using the formula , where N is the 
total number of cells. This value has been 
found to produce relatively square core cells 
for most designs.

N 2⁄
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Configuration  (continued) Row indent ratio  is the ratio of the target 
length of the middle row of cells to that of the 
top row. This value must be between 0 and 1. 
For designs with a significant number of row 
crossers added to the middle rows (thus 
increasing their width), the ratio should be 
decreased if the middle rows are much wider 
than those at the top or bottom of the design.

Output options If the Write nodal properties file  box is 
checked, a file of node capacitances is written 
out after the routing is completed. The name of 
the file is the same as that of the TPR netlist 
file with a .cap extension.

If the Label nodes with ports  box is checked, 
L-Edit places ports with node names on the 
layout. This is useful if manual modifications 
to the results of the routing will be necessary: 
individual nodes can be traced as they wind 
through the core.
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Tools > Extract

Opens the Extract  dialog.

Clicking Accept  saves the current settings without running the Extract  module.
Clicking Run  begins the extraction process on the active cell. Any instances are
temporarily “flattened” (except for those marked as subcircuits).

The Extract  dialog contains three tabs:

� General

� Output

� Subcircuit

Tools Menu
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Extract – General

Extract definition file The name of the input file containing the 
extractor device and interconnection 
definitions. You can choose from available 
files and directories with the Browse  button.

SPICE extract output file The name of the output file containing the 
extracted netlist. Enter the name (or use the 
default). You can choose from available files 
and directories with the Browse  button.

Bin size To improve performance, the extractor divides 
the layout into a grid of square bins, which are 
handled individually. The Bin size  is the 
length of one side of a bin, in Locator Units. 
Binning is not used if the Recognize 
subcircuit instances  box in the Subcircuit  
tab is checked.
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Extract – Output

Note: The Write shorted devices  check box only applies to those devices in the extract
definition file containing the IGNORE_SHORTS flag.

Write node names If this box is checked, the names of nodes are 
included in the descriptive comment lines that 
are written into the netlist with each device 
statement.

Write device coordinates 
(Locator Units)

If this box is checked, the location of each 
device in the layout is placed in a comment line 
in Locator Units.

Write shorted devices If this box is checked, shorted devices are 
written into the netlist as comments; otherwise, 
they are ignored.

Write nodes as Ports in the layout can be used as node or 
element names in the netlist. This option 
controls whether nodes are written as internally 
generated numbers (Integers ) or as descriptive 
strings (Names ).
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The strings produced by the extractor are the 
hierarchical names; each instance involved in a 
node is mentioned and separated from the 
others by a slash /, with the port name at the 
end. (Instances that are unnamed in the layout 
are named automatically by the extractor.) For 
example, the node name U1/alpha/in  describes 
a port in  contained by an instance alpha , which 
in turn is contained by an instance U1.

A port on the device recognition layer for a 
particular device, and completely enclosed by 
that device, is used to name that device in the 
netlist.

Write nodal parasitic 
capacitance

Computes the capacitance with respect to the 
substrate of each node in the circuit using the 
area and fringe capacitance constants specified 
with the Setup > Layers  command. The node 
to substrate capacitance of N is written to the 
netlist as a capacitor between N and the 
substrate/ground (0).
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Note: L-Edit cannot determine if other nodes in the circuit are ground nodes. If other
nodes are to represent ground, then they must be renamed 0 — or any of its
equivalents — in the netlist.

Write nodal parasitic capacitance  is not 
generally turned on for LVS since the other 
netlist (typically derived from a schematic) will 
not contain parasitic capacitors associated with 
nodes.

Ignore nodal parasitic 
capacitance less than

Specify a limit, in femtofarads, below which 
the nodal parasitic capacitance will not be 
written to the netlist. This field is disabled 
when the Write nodal parasitic capacitance  
box is unchecked.

Write values in scientific 
notation

When this box is checked, numerical values are 
written in scientific notation rather than in 
engineering units.
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Extract – Subcircuit

Write verbose SPICE 
statements

Writes resistors, inductors, and capacitors to 
the netlist file with the device value preceeded 
with a R=, L=, or C=. For example, a capacitor 
would have the following format: Cxxx  n1 n2 
modelName  C=cValue .

Label all devices For each device, creates a two-dimensional 
port in the layout at the location of the device 
from its recognition layer. The port is placed 
on the layer specified in the Place device 
labels on layer  drop-down list. The text of the 
port is the text of the element name for the 
device.

SPICE include statement This field is written unaltered as the second 
line of the output netlist. Typically, an .include 
file  command is entered, where file  represents 
a model or subcircuit file name.

Recognize subcircuit 
instances

Activates the subcircuit recognition feature.
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Subcircuit recognition 
layer

The name of the subcircuit recognition layer 
(SRL). This mandatory layer should not be a 
layer containing electrically significant 
geometry.

Write netlist as a subcircuit 
definition (.SUBCKT ... 
.ENDS)

If this box is checked, the entire netlist is 
written in subcircuit format: a .subckt  
command appears before the first device, and 
an .ends  command appears after the last 
device.

Flag improper overlaps This box controls the reaction to geometry 
violations: under- or over-filled connection 
ports or geometry that overlaps the subcircuit 
boundary. When the box is checked, warnings 
are displayed. When the box is unchecked, 
warnings are suppressed. Suppressing 
warnings can be useful when extracting auto-
routed standard cell designs with known over- 
and under-fill characteristics.

Ignore subcircuit 
connection ports with 
names

If a port in the layout has either one of the 
predefined names or the one user-defined 
name, it is not recognized as a subcircuit 
connection port. (For more information see 
Designing Subcircuit Cells.)
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Ignore subcircuit connection port on layer  
contains the name of a layer on which intruding 
geometry and subcircuit connection ports will 
not be recognized. In addition, any geometry 
on the Icon layer (often used for documentation 
purposes), as defined with Setup > Special 
Layers , is ignored. (For more information see 
Designing Subcircuit Cells.)

Subcircuit cross port 
names

If a port in the layout has either one of the 
predefined names or the one user-defined 
name, it is not recognized as a subcircuit 
connection port. (For more information see 
Crossing Over a Subcircuit Instance.)
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Tools > Cross Section

Opens the Generate Cross-Section  dialog, prompts for options, then generates a
cross-section view of the layout in the active cell.

Tools Menu

Process definition file The name of the text file that defines the 
cross-section process. This file must exist prior 
to generating a cross-section. You can choose 
from available files with the Browse  button. 
(See XST Files for more information on 
process definition files.)

Pause after first step When this option is checked, the cross-section 
view is developed one process step at a time. 
Click the Next Step  button to proceed through 
each step.
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Vertical coordinate (Y) The position of the cross-section in the layout. 
To choose the position graphically, click the 
Pick  button. The cursor becomes a horizontal 
line that can be dragged up or down. Clicking 
the mouse button over the desired position 
reopens the dialog with the y-coordinate in the 
text field.

Exaggeration factor Since process depths are measured in 
technology units, the displayed thicknesses of 
layers in cross-section scale with the current 
Work Area magnification. At very large or 
very small magnifications, it may be 
impossible effectively to display cross-section 
views at a 1:1 horizontal-to-vertical aspect 
ratio. The two fields (numerator and 
denominator) specify the fraction by which to 
compress or expand the vertical axis of the 
cross-section.

Auto-fit in window Automatically zoom the cross-section to fit in 
the available window.
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Tools > Macro

Opens the Macro  dialog to add, remove, and edit User Programmable Interface
(UPI) macros. The Macro  dialog is the interface to the UPI.

There are eight buttons associated with UPI macros:

� Run  – Executes the macro highlighted in the Macros  list.

� Close  – Closes the Macro  dialog.

Tools Menu

Macros The list of registered macros. Click on a macro 
to select it.

Macro Files The name and complete paths of all loaded 
macro files. Click on a macro file to select it.

Load Files at Startup When this box is checked, the Macro Files  
listed are loaded when the application is 
started.



C o m m a n d  R e f e r e n c e T o o l s  >  M a c r o

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

� Mode  – Opens the Mode Setup  dialog where you specify the UPI operating
mode.

� Edit  – Invokes the macro text editor and opens the selected macro file for
editing.

� Add  – Invokes the Open  dialog to load a macro file and add it to the Macro
Files  list. (See File > Open  for more information on the Open  dialog.)

� Delete  – Unregisters all macros defined in the highlighted macro file and
unloads the file from memory.

� Setup  – Opens the Interpreter Setup  dialog and specifies the interpreter
setup parameters.

Mode

The Mode Setup  dialog specifies the UPI operating mode.

Graphics mode When the On option is selected, the L-Edit 
screen is updated after every relevant UPI call 
in a user-defined macro. When the Off  option is 
selected, the screen is refreshed only on 
completion of the macro.

Quiet mode When this box is checked, all alert boxes are 
suppressed. This mode is required for batch 
processing.



C o m m a n d  R e f e r e n c e T o o l s  >  M a c r o

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Setup

The Interpreter Setup  dialog specifies the interpreter setup parameters.

Location of header files The complete path of the directory containing 
the L-Edit interpreter header files. These files 
are used by L-Edit to interpret the macro. Click 
the Browse  button to locate a particular file.

Log file Enter the name of the log file to which macro 
errors will be written. Click the Browse  button 
to locate a particular file.



C o m m a n d  R e f e r e n c e T o o l s  >  R e p e a t  M a c r o

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Tools > Repeat Macro

Runs the last macro executed by the Tools > Macro  command.

Tools Menu



C o m m a n d  R e f e r e n c e W i n d o w  >  C a s c a d e

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Window > Cascade

Arranges windows in overlapping fashion, starting from the top left corner of the
display area, so that the title bars are visible. The active window remains active
(in front).

Window Menu



C o m m a n d  R e f e r e n c e W i n d o w  >  T i l e  H o r i z o n t a l l y

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Window > Tile Horizontally

Tiles windows from top to bottom.

Window Menu



C o m m a n d  R e f e r e n c e W i n d o w  >  T i l e  V e r t i c a l l y

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Window > Tile Vertically

Tiles windows from left to right.

Window Menu



C o m m a n d  R e f e r e n c e W i n d o w  >  A r r a n g e  I c o n s

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Window > Arrange Icons

Arranges any minimized window icons present in rows starting at the bottom left
of the display area.

Window Menu



C o m m a n d  R e f e r e n c e W i n d o w  >  C l o s e  A l l  E x c e p t  A c t i v e

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Window > Close All Except Active

Closes all open windows except for the active window.

Window Menu



C o m m a n d  R e f e r e n c e W i n d o w  >  ( o p e n  w i n d o w s  l i s t )

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Window > (open windows list)

All open files are listed in the order they were opened. The active file is indicated
with a check (√).

Window Menu



C o m m a n d  R e f e r e n c e H e l p  >  L - E d i t  U s e r  G u i d e

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Help > L-Edit User Guide

Opens the L-Edit User Guide.

Help Menu



C o m m a n d  R e f e r e n c e H e l p  >  A b o u t  L - E d i t

L - E d i t  O n l i n e  U s e r  G u i d e C o n t e n t s I n d e x H e l p

Help > About L-Edit

Displays program information.

Memory

Button calls a dialog that displays system and memory information.

Support

Button calls a dialog that provides information on how to contact Tanner EDA
Technical Support.

Help Menu
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